KAPOW

Welcome to the Kapow forum. Here you can get help, use your skills to help others and enjoy hanging out in the company of other Kapow Robot Developers.


Solution for Getting 'Server offline' when running a Kapow Kapplet

Share
avatar
Shyam Kumar
Ranks

Posts : 73
Points : 1622
Join date : 2013-07-05
Location : Kerala, India

Solution for Getting 'Server offline' when running a Kapow Kapplet

Post by Shyam Kumar on Tue Jul 05, 2016 4:36 pm

If a Kapow Kapplet is created in a custom project (i.e. not the Default Project) it might fail to run and throw a "Server offline" error message.


This happens when the project where the Kapplet has been created doesn't have a "Service Cluster" configured.



To configure the "Service Cluster", follow these steps:



  1. Go to the Kapow Management Console --> Admin --> Projects
  2. Open the settings of the project (the one where the Kapplet was created) by clicking the icon in its "Edit" column
  3. Go to the "Services" tab
  4. For "Service Cluster" select the cluster on which the Kapplet should run
  5. Save the changes


After configuring the "Service Cluster", the Kapplet should run without throwing the "Server offline" message.

    Current date/time is Thu Jul 27, 2017 1:36 am